Discoverer 10g Viewer - Changes and New Functionality

Logging into Discoverer Viewer
Each time you log into Discoverer Viewer, you will need to enter your username and password. The Database field
should default to the correct value of CLPROD. If it does not, simply enter CLPROD into the field.

The user no longer has to create connections in order to access the application.

ORACLE Discoverer Viewer

Business Intelligence
. _______________________________________|

-

nnect =
Enter connection details.
Enter your connection details below to connect directly to OracleBl Discoverer.

* [ndicates required field

Connect To |0racle Applications |+

[* User Name |

* Password |

* Database |[C1PROD
End User Layer |

Locale |L::u:a|9 retrievad from browser |+

Users must select the correct Discoverer responsibility in order to be able to view reports. If you leave the default
responsibility as the value and choose to continue, you will be unable to view reports.

Account Details: Select Responsibility
More than one Responsibility exists for the account you have chosen. Please select | Cance| Lontinue |
the ane you wish to use below

Responsibility
Select a Respansibility

Loczle Locale retrieved from browser
Database User Name JCEDDY
Database C1PROD
Connection Type APPS
Responsibilty | ARC-DISCOVERER-ARC w

_Cancel | | Contifue |

Selecting/Opening a Discoverer Workbook
The user will see the following changes to the list of available workbooks:

1. Focus —allows the user to hide all workbooks except for the one selected.

2. Expand/Collapse Options — allows the user to drill into a specific worksheet instead of defaulting to the first
worksheet. User must click on the worksheet link in order to open a report.

3. Owner —the owner, or report creator, is no longer attached to the Workbook name. There is now a separate
column to identify the username who saved and shared the report with the Discoverer Viewer.

4. Last Modified — displays the day and time the report was last saved.



Result List

Fetrash

Expand &ll | Collapze Al
SRy e

:
FocusHame Description Oramner Last Modified
3 ? Discovarer Workboaoks
[,
£l B 5 ARC 1099 Preparation Report  This workbook identifies vendors paid during — aRc Tuesday, January §, 2008 10:31:07 AM EDT

the perod selectad that meet the reguirsments
for an IRS Foern 1099

D & ARG 1053 REPORTING ALL The TB wurksheat is & high-level summary tial SUPPLIERARE Thursday, March 19, 2009 06:10-06 AM EDT
PAYMENTS FOR IRS AUDIT OIS balance. Tha TB Dstail vorkshest prowides

L document-level detail for specific SGL
[ accounts. The Financial TB is & YTD trial
(WY balance
@ ¥ W ARC 1099 Reparts This workbook identifies vendors paid during — aRC Tuesday, March 4, 2008 06:16:52 AM EOT

the perad selected that meet the reguiraments
o for an RS Form 1059

I gy

Summary with TIN Subtatal

Ustail

Edit Parameters

For parameters that are set up with a 'LIKE' operator, users will no longer be prompted with the options of 'Exact’, 'Starts
with' or 'Contains'. Users will now need to use the '%' as a wildcard. In the example below, the user would need to
enter 'BPD%' in order to return all BPD funds. In Discoverer 9i Viewer, the user would enter 'BPD' in either the 'Starts
with' or 'Contains' field. In Discoverer 10g, the value 'BPD' will not return data until the % is added to the end of BPD.

Parameters Needed
Select values for the following parameters
# |ndicates reguired field
* Enter () aR/09-09
Period
Exarmple NOWVD2-03
= Fund Like EF“E@_&]]
Example ‘BPD% (Use % a=s a wildcand
G

Additionally, users no longer have to click the Edit Parameters button in order to modify the parameter values once a
report has been run. The values can be modified and the report will run after selecting the 'Go' button.

For Oficial Business Use Dnl\l

¥ Parameters
Select values for the fallowing parameters.

# lindicates required Neld

% Enter

boniog | MARI09.0%

Example MOW02-03
= Fund Like |‘BPDOSGOSENINY
Exammple ‘BPD% (Use % as o wikicand
! GE |
¥ Table
>Tools Lavoyd Eormat Stoplioht Son Eows and Columes

Page ltems Period | |1AR/09-09 »

¥ Fund *Budget Authonty *Commitments ®Obligations ®Expenddures ™ Total Actuals %

1 BPDOSEDSEDIXX 187 252,000 00 501.617.6% 38,183,082 38 BG6,842731.73|125,532 46240 §




Actions

The Rerun Query, Export and Printable Page buttons can now be found under the Actions section on the left above the
Worksheet links. Some of the options that were under the old Presentation Options are now located under the
Worksheet Options found under Actions. Users no longer have the ability to hide individual buttons like they could via
the Presentation Options.

—d N 1 .-

BEe '}

Save as

Rever to saved

Printable page

Export ¥ Parameters

Send a3 email

T m————— Select values for the follg
# |ndecates required fiesd

Worksheets * Enter fiag)
Penod
S0F Examp

Sigius of Funds

Modify worksheet
Table>Layout

Discoverer 9i Viewer allowed the table layout, arrangement of columns and headers, to be modified by clicking on the
column that you wanted to move and dragging it to the desired location. Discoverer 10g Viewer does not offer drag-
and-drop functionality, but offers the same functionality through the Tools menu. By clicking on Layout from the Tools
menu, the user is provided a series of drop-down lists in order to define which field to move where.

¥ Table
¥ 1lools pypll Format Stopighl Sl Rows eed Coumny
(—Mm | | Funds Awailable % | Lofl of Fund | [ Ca) file ]
Lefl of Fund
Page items Pefod | (AR09-09 » |Lef of Cost Contad
Left of Budget Authorty
Left of Commitments Columns 19 of 1 9 Cakgfns | F 5
Leh of Oblgations |
*Fund ®Cost Gl Lot of Expanditures Commiments ™Obbgabons ™ Expenditres PTotal Actuals ™% Used  ®Funds Available
Lef of Total Actuals
1 BPDOSE0SENTN BPDS 1 10 R R 0o 000 =502 25501112 100 00% -255.011.12
O ot T Al able
7 BPDISELSENINY BPDE300 Lef of Period ooa 000 608018376 &.080,183.76 100.00% B 080,183 T&
! e Right of Peried = o v — e =
1=l =] BP0 ; i 1 Bl TTE R 0 g 54 176
3 BFDISEDSEQTXN B L:{':!E!JT'_ Page lome ] a 00 54 TT5. 28 54 71528 100 00% 54 TTE .28
] BPDOSS0SENSNK BPOFEESO00 104,421,840 00 00a 000 0.00 0.00 0.00% 704471840 00
Formatting

Table>Format

Use the formatting options to alter the font/background colors, bold, underline, etc. Simply select the column you want
to format and then change the format via the formatting toolbar.



¥ Table
¥ Tools Lavout Format Stoplight Sort Rows gnd Colimns

(EII_,L | Background [_g GoJ| Font [_g E‘]I More__|

Page ltems Pefiod MAR/09-09 v|

Select
,_—.,\_:' *Fund ¥ Cost Center ™ Budget Authonty ™ Comm|

1 _ BPD5110000 0.00

2 BPOS300000 0.00
| . SORRESRSERRVY conoconnnn 0 oo

Conditional Formatting
Table>Tools>Format>Create Conditional Format

Conditional formatting enables the user to highlight values within a column that meet a specific condition. This
formatting tool makes analyzing data at a quick glance possible. For example, you may want to highlight all cells where
the expenditure total by cost center is greater than $300,000. In the example below, all rows have been retrieved with
special emphasis on the cost centers that have expenditures greater than $300,000.

Create Conditional Cell Format
Craate a new conditional farmat by specifying which column to format and formatting options.
# Indicates required fiald.

Mame
w Mame |Expenditures > 3300 000 |

Selections
Select a column to format, or a data point condition to identify particular values.
Item Operator Value
Expenditures * (| Greater Than (=) - | 300000
Format
Select formatting options to apply to the specified cells.
Font
Specify font attnbutes
Style Bold |Apply |
[talic w
Underline w

@ TIP Click in the paletie to select a color or enter color information as [#FFFFFF)
Background |#FFFFO0 O Fant |#000000 B




¥ Table
¥ Tools Lavou! Format Siopbghi Sord Rows and Colmns

Columns 1-9 of 10

*Fund ¥ Cost Center ™Budget Authority ™Commitments ™ Obligations| ® Expenditures |*Total A
I I
1 BPDOSG0SENYX BPDS110000 0.00 0.00 0.00 255,011.12 255 1
2 BPDOSG0SENYNX | BPDS300000 0.00 0.00 0.00) 6,080,183.76) &.080,
3 BPDOSG0SENSX | BPD3650000 0.00 0.00 0.00 54.775.28 54.]
4 BPDO560SENSXY  BPDFEESDOD 104 421,840.00 0.00 0.00 0.00
5 BPDOSGOSEDNSXE BPDA300000 0.00 0.00 0.00 387,939.36 38T
[ BPDOSGOSENSXX  BRO3230000 0.00 0.00 0.00 83416.48 B34
= BONAEENCEANDYY BN NN (i 0 a0 nnnHﬂW 4144

Stoplight Formatting
Table>Tools>Stoplight

Stoplight formatting is very similar to conditional formatting with the difference being that there is the added ability to
format data in a column using three ranges: Unacceptable, Acceptable and Desirable. In the example below, a desirable
Expenditure Amount is less than $100K, an unacceptable Expenditure is anything greater than $1M and any amount in
between these values is defined as acceptable.

¥ Table
¥ lools Layout Format Stoplight Sod Eows and Columns
(Furmat Expendituras A | LInacceptable 1000000 '—~ -Acceptableg - Desirable 100000 l; I Go )

@ TIP Acceptable range falls between unacceptable and desirable valuss

Page ltems Period | pARDS-09 V:

Columns 1-9 of 10 & Lef |-

*Fund *Cost Center ™Budget Authority ™Commitments ™ Obligations ™Expenditures ™Total Actuals

| | | |

1 BPDOSE0SENSXX BPDE110000 0.00 0.00 0.00 255,011.12 255,011.12
2 BPDOSE0SENYX BPDE300000 0.00 0.00 0.00 6.,080,183.76
3 BPDOSE0SENSXX BPD3650000 0.00 0.00 0.00 54,775.28
4 BPD0550SENSXX BPOFEESDO0 104.421.840.00 0.00 0.00 0.00
5 BPDOSEOSENSXX BPD1300000 0.00 0.00 0.00 387.939.36 387.939.36
] BPDOSEOSEQX BPDAZI0000 0.00 0.00 0.00 83.416.48

Rows and Columns
Table>Tools>Rows and Columns

The Rows and Columns option allows the user to define the number of rows and columns to display while viewing the
results of a report in Discoverer. This will not affect how the data is exported or printed as either action will cause all
rows to be displayed.



¥ Table
¥ Tools Layout Format Stookighi Sort Rows and Columns

[* Rows |1CICI = Columns |‘:'I

(0 800 (0 &og

| ':ﬂ]

Page Items Penod | p)2R/09-09 V'|

*Fund *Cost Center ™Budget Authority ™Co

Text Area

This area can be used to display additional information, hints and suggestions related to the current worksheet. Only
the report creators have the ability to add/modify text in this area, but the information is visible to Discoverer 10g
Viewers.

Page Items Pefiod | MAR/09-09 v
5 Rows % Down W Rows 1-5 of 52, Columns 1-9 of 10
= Fund *Cost Center ™Budget Authority ™ Commitments ™Qbligations ®™Exp
|
1 BPDOSG0SE0N®X BPDS5110000 0.00 0.00 0.00 2
7 BPDOSGOSE0NSXY BPDS300000 0.00 0.00 0.00 6,0
3  BPD0OSGOSE0NSXX BPD3650000 0.00 0.00 0.00
4 BPD0560SEDNSXX BPDFEESDOD 104,421,840 .00 0.00 0.00
5 BPDO560SEDNSXX BPD1300000 0,00 0.00 0.00 3
5 Rows [%| Down & Rows 1-5 of 52, Columns 1-9 of 10
Else this report to view the status of your funds by cost ce nter.]
ast updated by JCEDDNY on 3/1/2008

Email
Discoverer 10g Viewer offers a quick link to attach the current worksheet, in a specified format, to an email. The user
has the ability to enter multiple recipients, subject line and additional text.



Send Email
ﬁ’he worksheet was exported successfully. The email will contain the document as an attac hment]

# |ndicates required fiald

* Sender |JanE doe@bpd treas gov
_|.'| n. oS oompany com
= Recipient |ji|l|an.edd5.-@bpd.lreas.gm

john dos@company. com, @ané dos@company. com

cc |
jBhn dos@company com, ans dos@company, com
Bcce |
jhn, doe@oompany com, @ne doscompany, com
Subject [****TEST"***
Entar amy teod

Body |aAmtached is your month Status of Funds report for your review

Ender any teod

ew Altachment ‘

Export Crosstab to Microsoft Excel Pivot Table

Workbooks that are created as a Crosstab, instead of the more common Table, have the ability to export into a pivot
table in Microsoft Excel. Only workbooks that are set up as crosstabs have this option; most workbooks are not set up
as crosstabs.

p-Tuclli Layow! Formai Siopiighl Rows and Colrmns

Page ltems PE0d | nMaR/09.09 ~| Find | FHBs039RE000 ¥

»Bfy »2002  »2003 »2004 »2006 »2007 =2008 2009  Sum
Funds Avallable Funds Available Funds Availsble Funds Avalable Funds Available Funds Avallable Funds Avaiiable

FMOC | | ! .

=00 NULL NULL HULL MULL 5,337 25 B0 486 63 NULL 85,823 84
" 11 NULL NULL HULL MULL 116,950 37 93400939 15186427 64 {7 237 287 40
*12 NULL 90,807 03 167.601.00 MULL -B4.910.74 22534561 519388933 5502732 23
*13 NULL NULL MULL MLALL 1,574 28 -1.303.27 NULL -8.877.53
= -5,836.36 66,022 19 84 74714 3350 2,734 98 157720261 108184771 107466376
=22 NULL NULL HULL MULL 2187 24 706257 NULL 9,249 81

»23 HULL MULL NULL 24897 157,363 37 -193.018 60 23,807 49 58, 213.75

S P amas PR S san oo s sos oo S ane oo Ans soo o Sum aor o




e—————————————————————————|
Connegt > Workbooks > ARG Federal Status of Funds - Status of Funds by MOC 2 >
Choose export type

Use the drop-down list to specify the export file format.

CSV (Comma delimited) (*.cav) W

C3Y (Comma delimited) (*.csv)

DIF (Data Interchange Format) [~ dif)
Formatted Text (Space delimited) (*.prm)

GIF Image (*.gif)

Hypar-Text Markup Language (archived) (* zip)
Microsoft Excel Workbook (* xls

Microsoft Excel Workbook with Pivot Table |
Oracle Reports XML (" xml)

PNG Image (" png)

Portable Document Format (FDF) (" pdf)
SYLK (Symbolic Link) (* slk)

Text (Tab delimited) (.txd)

Web Query for Microsoft Excel 2000+ (*.igy)
WKS (Lotus 1-2-3) (" wks)

Preferences

Printable Page Options
The printing options have been expanded to include the ability to include/exclude both the title and text area while
printing a worksheet, repeat headers on every page and the ability to modify various Page Setup items (ex. paper setup,

margins, scaling, column sizes and wrap text).

Discoverer no longer auto sizes the report to fit to one page wide. Users will need to modify the margins, scaling and/or
column sizes in order to print all the columns on one page if desired

Printable Page Options
Set the options to generate a printable Portable Document Format (PDF) document of your workishest \Cancel ) | Preview sample ] | Print

Contant Page Setup '

Paper Setup
Siza |Letter (11 x 8.5) b
Onentation O Portrat & Landscape

Margins
Top (025 | Bottem 025 |
nches nches
Leit [0 | Right 0 |
Inches Inches
Scaling

Set the scale of the pnnted workishest
Scale | 100% v

Column Sizes
Set the width of the printed columns

Fund Budget Authority Commitments Obligations Expenditures Total Actuals % Used Funds Available % Available
Column size (inches) [167  |[167 | 154 147 |[135 [1.28 0.93 149 [1.15
& TIP Maximum width of a single column: 10.45 {Inches)

[#] Always wrap text when size exceeds column width

Revert to Saved
The Revert to Saved option will undo any formatting or table layout changes that were made during the current session.
The values for the parameters will not change, but the report will be formatted according to how it was last saved.



Actions

Rerun query

Save

Save as
(Revert to saved )
Printable page
Export

Send as email
Worksheet options

¥ Parametersg

Select values fo
* |ndicates requirs

Cs
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